Genshin · Forums
EN

Requirement question ios

Originates from: Tavern
145
3
7
1
0
Post Published: 07-31

Can this run on a regular iPhone 8 not the plus?

7
1
0
Reading is good, commenting is better::
  • All comments
  • Author only
Sort:Ascending
Manage

I believe that the operating system has more bearing than the device used as described in the email being invited to the closed beta (which has ended):

"must be installed on your iOS device using 8.0 or later, or Apple TV using tvOS 9.0 or later"

07-31
Replies
1
Manage

regular 8

bruh

08-01
Replies
1
Manage

No, They say that the game can only run on higher devices in the cb sign ups

08-01
Replies
0